Блог на Rails. Урок #2: Bootstrap 4

10
87



Второй урок по созданию Блога на Ruby on Rails. В этом уроке я расскажу как подключить Bootstrap 4 к приложению на Rails.

Ссылка на репозиторий проекта:

Официальная страница Bootstrap 4:
Репозиторий Bootstrap 4:

Заходите на наш сайт:

Nguồn:https://quydinh.com/

10 COMMENTS

  1. Здравствуйте а можно сделать пару уроков по чистому руби и нестандартному использованию… Например работа с android и 2D графикой… Благодарю за ответ и полезный контент)

  2. Создаю файл sass, прописываю, но не срабатывает. Перезапуск сервера не помогает.

  3. Суем эту строку в GEM файл, это тоже, и это, и на всякий случай это. Блин, хоть бы одно объяснение что и зачем. Как я должен понять, что вот именно это мне нужно подключить? Сейчас например новая версия рельсов, и бутстрапа, там на гитхабе нет того что ты указывал в гемфайле. У меня ничего не заработало и выдало ошибку JScript runtime does’t support ES6. Please update or replace your current ExecJS runtime. На гитхабе в факе указано установить popper_js – я установил, прописал в гемфайл, но ошибка осталась. Решение нашлось через час копания в интернете – нужно установить на виндоус nodeJS. Охуеть просто! Чтобы ссылка стала синенькой – ебаться с кучей GEM'ов, и еще и инсталлировать дополнительное ПО? Ебанись! В CSS файл несудьба дописать одну строку a {color: blue; font-weight: bold;}?

  4. у кого не устанавливается буут : curl -sL https://deb.nodesource.com/setup_10.x | bash – && apt-get install -y nodejs

  5. Подскажите пожалуйста, у меня в программе VIM нету слева иерархи вообще. И я не могу смотреть другие файлы и их создавать. Подскажите пожалуйста, что сделать, чтобы это появилось.

  6. "pull-xs-right" и "float-xs-right" не заработали. Вместо xs перепробовал sm, md, lg, xl. Так ничего и не произошло. Пытался просто "float-right" – также неудачно. В итоге получилось через: "navbar-toggler-right"

LEAVE A REPLY

Please enter your comment!
Please enter your name here